Back to overview
Maintenance
Upgrading system and migrating data to support more flexible plan assessment.
Jun 21, 2026 at 10:00am UTC
–
Jun 21, 2026 at 11:00am UTC
Affected services
Rico UI
Rico API
Resolved
Jun 21, 2026 at 11:00am UTC
Maintenance ended
Affected services
Created
Jun 21, 2026 at 10:00am UTC
Rico will be unavailable during this time.
Affected services